La Geek Attitude

A la recherche de solutions pour améliorer le quotidien


Poster un commentaire

Migration Jeedom V3.0: expérience, suite…

Je suis du genre tête de mule et cela m’a vraiment frustré de ne pas pouvoir passer à cette version 3 pour deux plugins qui ne sont pas à jour….

J’ai donc fouillé sur le forum et j’ai trouvé des informations intéressantes qui m’ont permis de contourner le problème pour ces deux plugins.

J’ai donc modifié le fichier php localisé dans le répertoire Desktop/php et j’ai suivi ces instructions:

  • mettre col-lg-10 à la place de col-lg-12
  • supprimer  » bootstrapSwitch »

Maintenant, mes deux plugins fonctionnent parfaitement.

J’ai récupéré les widgets et sauvegardé les commandes pour chaque équipement et tout semble actuellement être en ordre, hormis une erreur SQL au redémarrage mais qui s’est réglée par un reboot supplémentaire.

Il me reste à comprendre l’erreur que j’ai quand je tente d’envoyer un rapport de mes valeurs historisées par mail et avancer le plugin Arduidom sous cette v3.

A suivre…


Poster un commentaire

Migration Jeedom v3.0: expérience

J’ai tendance à toujours vouloir être à la page mais pour la domotique, je me tempère un maximum pour ne pas avoir de problèmes avec madame si plus rien ne fonctionne.

Après avoir un peu attendu, j’ai tenté le passage à la v3.0 car le rapport mensuel des vues est une fonction que je voulais au départ développer via un plugin mais j’ai abandonné l’idée en sachant que cela allait être intégré dans cette version.

J’ai d’abord fait l’installation de cette v3 sur une machine virtuelle pour y charger un backup de la 2.4.6.

Après cette restauration, j’ai donc désactivé tous les plugins, forcé la mise à jour de la v3 et celle de tous les plugins dans un second temps. Suite à cela, la réactivation des plugins a été effectuée et j’avais toujours accès à Jeedom.

Confiant, j’ai donc entrepris la mise à jour de la Jeedom SMART en v3 en suivant la même méthode. Désactivation des plugins, update du core, des plugins et réactivation.

A priori, tout semblait être OK…. Sauf que plusieurs plugins ne fonctionnaient pas. Il faut dire que je n’ai pas revérifié l’ancienneté de chacun. Certains, fait en version 2.3 ou 2.4 fonctionnaient parfaitement… Sauf que 2 plugins, télécommande free and freeSMS sont toujours estampillé v1.2 et impossible de les ouvrir ou de recréer de nouveaux équipements.

Je vais donc de ce pas écrire un petit mot sur le forum afin de savoir si ces plugins seront mis à jour pour la v3.

J’ai quand même pu essayer la fonction d’envoi de rapport. Elle a fonctionné sur l’environnement de test mais pas sur la SMART.

J’avais également perdu les widgets pour l’état de mes volets.

J’espère pouvoir refaire l’essai quand les plugins problématiques seront disponibles pour la v3… En attendant, je suis revenu sur le 2.4.6 en restaurant le backup et forcé l’installation de quelques plugins dont le Zwave.

Mais là, encore une mauvaise surprise, j’ai perdu les commandes de plusieurs plugins comme HarmonyHub où j’ai du supprimer les équipements et recommencer la configuration. Le plugin Widget avait perdu son icône. J’ai effacé le plugin pour le recréer et je ne l’ai plus dans le Market…. Il va falloir s’en passer.

Voilà comment s’occuper une après-midi à tenter de ne pas se faire disputer parce que plus rien ne fonctionne.